freeswitchforum.com

Форум поддержки FreeSWITCH

FreeSWITCH is a registered trademark of Anthony Minessale. Official FreeSWITCH site.

Текущее время: 13 ноя 2019 08:20

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 15 ]  На страницу 1, 2  След.
Автор Сообщение
 Заголовок сообщения: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 19 фев 2019 13:23 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Ни как не могу установить голую версию Freeswitch 1.8.5 без FusionPBX зашел на сайт Freeswitch https://freeswitch.org/confluence/display/FREESWITCH/Debian 9 Stretch как положено прочитал документацию и начал вставлять код:

apt-get update && apt-get install -y gnupg2 wget wget -O - https://files.freeswitch.org/repo/deb/freeswitch-1.8/fsstretch-archive-keyrin... | apt-key add -

echo «deb http://files.freeswitch.org/repo/deb/freeswitch-1.8/ stretch main» > /etc/apt/sources.list.d/freeswitch.list echo «deb-src http://files.freeswitch.org/repo/deb/freeswitch-1.8/ stretch main» >> /etc/apt/sources.list.d/freeswitch.list

# you may want to populate /etc/freeswitch at this point.

# if /etc/freeswitch does not exist, the standard vanilla configuration is deployed

apt-get update && apt-get install -y freeswitch-meta-all

В терминал добавил в инстал debian записи о установки и сделал update и install, вот тут и начались зависимости. Устанавливал на голую версию Debian 9 64bit AMD, перед установкой обновил debian через update и upgrate. Мои конфигурации компьютера процессор intel pentium G-4560, оперативка 4ГБ DDR4, материнская плата H110M D3 Gigabite, жесткий диск WD Purple 1ТР и дополнительная гигабитная сетевая карта от TP-Link c поддерживаемой драйверами Linux. Что нужно еще установить перед установкой Freeswitch? Странно, что после начало установки, перед проверкой файлов пишет, что пакет сломан и дает зависимости всех тех файлов, которые идут в установке в Freeswitch. Создается ощущение что этих файлов нет по указанному адресу или ограничение у меня идет с провайдера.

Опыта по Linux у меня не большой, установку freeswitch делал от имени root для эксперемента и набора опыта, так что не боялся если что нибудь сломаю, всегда могу перейти на нулевую точку. По установки freeswitch 1.8 на debian 9 почти нечего нету в интернете, если и есть то только через git и само-сборка. Мог бы и установить FusionPBX и не морочить никому голову, что я уже и сделал для эксперимента, но задача состоит в том что нужно создать много-пользовательскую систему авторизации на сайт и каждый должен иметь доступ только к своему группе внутренних номеров и одного внешнего номера, что не дает FusionPBX, так что оболочку (web-морду) буду писать уже сам.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 19 фев 2019 14:09 
FreeSWITCH_GuRu

Зарегистрирован: 22 авг 2012 09:52
Сообщения: 1626
так что выхлопывает
Код:
apt-get install -y freeswitch-meta-all
?

_________________
Мобильные РФ 1.2 руб./мин. + НДС с посекундной тарификацией, CLI
Telegram: @rostel


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 20 фев 2019 09:55 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
А разве так можно? Он же начинает проверять по своим записям что у него должно быть в установках и потом обновлять по команде. Хотя это идея попробую отпишусь.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 22 фев 2019 20:28 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Ошибки которые выдает Debian

Этот код который я использовал по совету специалистов Freeswitch:

apt-get update && apt-get install -y gnupg2 wget wget -O - https://files.freeswitch.org/repo/deb/f ... e-keyrin... | apt-key add -

echo «deb http://files.freeswitch.org/repo/deb/freeswitch-1.8/ stretch main» > /etc/apt/sources.list.d/freeswitch.list echo «deb-src http://files.freeswitch.org/repo/deb/freeswitch-1.8/ stretch main» >> /etc/apt/sources.list.d/freeswitch.list

# you may want to populate /etc/freeswitch at this point.

# if /etc/freeswitch does not exist, the standard vanilla configuration is deployed

apt-get update && apt-get install -y freeswitch-meta-all

А это ошибки которые выдает Debian:

root@IP-ATS:~# apt-get update && apt-get install -y freeswitch-meta-all

Сущ:1 http://deb.debian.org/debian buster InRelease

Сущ:2 http://security.debian.org/debian-security buster/updates InRelease

Пол:3 http://files.freeswitch.org/repo/deb/freeswitch-1.8 stretch InRelease [3 210 B]

Пол:4 http://files.freeswitch.org/repo/deb/freeswitch-1.8 stretch/main Sources [4 189 B]

Пол:5 http://files.freeswitch.org/repo/deb/freeswitch-1.8 stretch/main amd64 Packages [63,0 kB]

Получено 70,4 kB за 2с (38,5 kB/s) Чтение списков пакетов… Готово

Чтение списков пакетов… Готово

Построение дерева зависимостей Чтение информации о состоянии… Готово

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: freeswitch-meta-all : Зависит: freeswitch (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-meta-codecs (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-meta-mod-say (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-abstraction (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-avmd (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-av (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-blacklist (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-callcenter (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-cidlookup (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-commands (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-conference (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-curl (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-db (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-directory (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-distributor (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-dptools (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-easyroute (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-enum (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-esf (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-esl (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-expr (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-fifo (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-fsk (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-fsv (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-hash (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-httapi (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-http-cache (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-lcr (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-memcache (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-nibblebill (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-oreka (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-png (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-redis (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-rss (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-signalwire (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-shout (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-sms (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-snapshot (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-snom (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-sonar (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-soundtouch (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-spandsp (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-spy (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-stress (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-translate (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-valet-parking (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-video-filter (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-voicemail (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-voicemail-ivr (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-flite (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-pocketsphinx (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-tts-commandline (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-unimrcp (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-dialplan-asterisk (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-dialplan-directory (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-dialplan-xml (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-dingaling (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-loopback (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-portaudio (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-rtc (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-rtmp (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-skinny (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-sofia (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-verto (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-cdr-csv (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-cdr-mongodb (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-cdr-sqlite (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-erlang-event (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-event-multicast (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-event-socket (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-json-cdr (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-kazoo (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-snmp (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-local-stream (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-native-file (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-portaudio-stream (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-shell-stream (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-sndfile (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-tone-stream (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-java (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-lua (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-perl (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-python (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-yaml (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-console (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-logfile (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-syslog (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-posix-timer (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-timerfd (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-xml-cdr (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-xml-curl (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-xml-rpc (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

Зависит: freeswitch-mod-xml-scgi (= 1.8.5~6~31281a0bf1~stretch-1~stretch+1) но он не будет установлен

E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 22 фев 2019 20:35 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Пробывал сделать так:

apt-get install -y freeswitch-meta-all

ответ те же ошибки.

Порекомендовали сделать так:

root@IP-ATS:~# apt-get install -y --allow-unauthenticated freeswitch-meta-all

бесполезно одно и то же...

Что не так?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 23 фев 2019 08:46 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Мои предположения: либо файлов на месте нету, либо провайдер по дороге меня закрывает на скачку файлов.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 23 фев 2019 09:15 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Читал в коментариях в freeswitch и наткнулся на этот пост:
Цитирую:
"For now, you can compile from source code or build your own packages locally. You will have to determine the dependencies yourself until they develop them for release."
Перевод:
На данный момент Вы можете собрать из исходного кода или построить свои собственные пакеты в местном масштабе. Вы должны будете определить зависимости сами, пока они не развивают их для выпуска.
Теперь встает вопрос как собрать из исходного кода или как построить собственный пакет и определять собственные зависимости


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 23 фев 2019 09:58 
FreeSWITCH_GuRu

Зарегистрирован: 22 авг 2012 09:52
Сообщения: 1626
зачем у вас подключены репы для версии buster?
Debian 9 - stretch

_________________
Мобильные РФ 1.2 руб./мин. + НДС с посекундной тарификацией, CLI
Telegram: @rostel


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 23 фев 2019 17:35 

Зарегистрирован: 19 фев 2019 13:13
Сообщения: 11
Ну во первых Freeswitch 1.8 делался для Debian 9 stretch и соответственно на их сайте https://freeswitch.org/confluence/displ ... +9+Stretch все эти коды сами выставили для установки. Потом я читал документацию по Debian 9 stretch там и было описано что именно таким образом он устанавливает под себя программы через репозитории. По документации по установки в Freeswitch 1.8 на Debian 9 stretch установка через гит хаб и pub, как написали они не производителен. Кстати я для эксперимента пробывал установить, что то не получилось. Все скачалось, но в установке были какие то проблемы кажется я пользователя неправильно вписывал. Потом я взглянул на версию скачиваемого дистрибутива была подпись нестабильная и дальше я работу всю прекратил по установке. Если подскажите как правильно устанавливать, буду только очень рад. Я так понимаю что я скачал не ту версию Debian?


Последний раз редактировалось marat.gabidullin 23 фев 2019 17:54, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Установка Freeswitch 1.8.5 на debian 9
СообщениеДобавлено: 23 фев 2019 17:52 
FreeSWITCH_GuRu

Зарегистрирован: 22 авг 2012 09:52
Сообщения: 1626
у вас уже не debian 9, а 10 стоит

_________________
Мобильные РФ 1.2 руб./мин. + НДС с посекундной тарификацией, CLI
Telegram: @rostel


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 15 ]  На страницу 1, 2  След.

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 8


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Powered by phpBB® Forum Software © phpBB Group
Русская поддержка phpBB